[トップページ] [FAQ 一覧]

対象:Workspaces

"更新プログラムを構成しています"でWorkSpaces が起動しない、ログインできない




問題


Windows 環境において、WorkSpaces アプリより AWS WorkSpaces にログインしようとしたところ、ログインに失敗しました。
状況を確認するために、リモートデスクトップによりログインしたところ、次の画面が表示されていました。


更新プログラムを構成しています。
7%完了
コンピュータをの電源を切らないでください



30分待ったところ、リモートデスクトップは強制的に切断されました。
その後マネージメントコンソールで確認したところ、ステータスが異常となっていました。

そこでマネージメントコンソールからWSを起動しても同じく"更新プログラムを構成しています"で停止していました。
先ほどから変わっていないようです。

原因


原因は不明です。おそらくWorkSpace特有の現象ではなくWindows 更新プログラムの問題と思われます。

対処




ステータスが"異常"な場合、マネージメントコンソールから手動で"停止"させます。
先ほどは"停止"作業なしで"起動"したため、更新プログラムの更新状態の止まったままであったようです。

これで次の画面となり更新プログラムの永遠の失敗から抜け出せました。


更新プログラムを構成できませんでした
変更を元に戻しています
コンピュータをの電源を切らないでください



これを何回か繰り返したらログインできるようになりました。1度だけではだめでした。何度か更新プログラムの構成に挑戦したところ無事完了したということです。

このチャンスに次のようなコマンドで修復を試みます。

sfc /scannow
DISM.exe /Online /Cleanup-image /Restorehealth



まとめ


"更新プログラムを構成しています"で異常になった場合、すぐに起動ではなく、一度"停止"してから再度起動する。
次の図ような感じです。

Windows Update 失敗時のWorkSpaces の再起動


【超重要】本ページは情報が古くなっている可能性があります。参考程度にしてください。








[ 一覧に戻る]


【注意事項】本ページの内容は個人的に調査した結果がであり内容が正しいことは保証されません。
またAWSサービスは常に改良、アップデートされており本ページの内容が古く誤った内容になる可能性もあります。変更になっても本ページが正しく更新されるとは限りません。
あくまでも参考程度でご覧ください。内容により発生したいかなる時間的損害、金銭的損害、その他の損害に関しても何人も保証しません。